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GIS-Exercise  
Sustainable Development Goals  

Click-by-Click 
 

 

The 17 goals of the UN 
The "Agenda 2030 for Sustainable Development" is a global United Nations action plan for people, the planet and 
prosperity adopted by the UN General Assembly in September 2015. With Agenda 2030, the member states of 
the United Nations have developed a roadmap for the "transformation of the world for the better" in the sense of a 
sustainable transformation of society, economy and environment by the year 2030. Agenda 2030 includes 17 
global goals divided into 169 subgoals (cf. indicators of the UN sustainability goals1). 
The 17 Sustainable Development Goals (SDGs) are political objectives of the United Nations (UN) that are in-
tended to secure sustainable development at the economic, social and ecological levels (see Sustainable Devel-
opment Goals2). The goals were designed in line with the development process of the Millennium Development 
Goals (MDGs) and entered into force on 1 January 2016 with a duration of 15 years (until 2030). In contrast to the 
MDGs, which applied in particular to developing countries, the SDGs apply to all states. If you want to get an 
overview of the sustainability goals, watch the UN-Video3. 

 
UN goals for a sustainable development 

Exercise: 
In the exercise, you will deal with one of more than 200 indicators on the 169 subgoals. Please note that not all 
indicators have comprehensive data (we would like to have data on all countries over longer periods for evalua-
tion purposes). A comprehensive description of all indicators can be found under List of indicators4. The path to 

                                                            

1 https://unstats.un.org/sdgs/indicators/indicators-list/ 
2 https://www.un.org/sustainabledevelopment/sustainable-development-goals/ 
3 https://www.youtube.com/watch?v=0XTBYMfZyrM&feature=youtu.be 
4 https://unstats.un.org/sdgs/indicators/indicators-list/ 

https://www.un.org/sustainabledevelopment/sustainable-development-goals/
https://www.un.org/sustainabledevelopment/sustainable-development-goals/
https://www.un.org/sustainabledevelopment/sustainable-development-goals/
https://youtu.be/0XTBYMfZyrM
https://unstats.un.org/sdgs/indicators/indicators-list/
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download the freely available original data is Database5. Before you start editing, please read the meta infor-
mation for the selected indicator carefully in order to assess whether a meaningful question can be edited and 
evaluated. 
Regardless of the selected processing level (Advanced, Basic or Click-by-Click), the following statements could 
be worked out in the document, for example: 
 In which direction does the selected indicator move worldwide? 
 Which country has the greatest progress/regression relative to the indicator to be evaluated in the period un-

der consideration? 
 Which region/continent on earth presents itself as problematic/progressive? 
 Compare some countries with respect to the indicator to be evaluated in the period under consideration. 
Try to establish connections with the global political situation or other knowledge about the topic. 
1. Try to understand and penetrate the topic on the basis of the literature. Take a very close look at the metadata 
description (thematic classification, methodology and validation, data quality ...) of the selected indicator so that 
you can specify your question precisely and interpret the results obtained correctly. 
2. Design a workflow for your data processing (tabular evaluation, GIS evaluation). 
3. Create a structure of your document (no process description or work report, style of a scientific paper). 
4. Evaluate your data and prepare it, both the table data in the form of measures and diagrams, and the geoinfor-
mation in the form of thematic maps. For this purpose you link the attribute data with suitable spatial data of the 
national borders, for which we need a common key in both data sets (a mostly numerical country code such as 
ISO 3166-1, compare e.g. https://www.laenderdaten.info/laendercodes.php). 

 
Different country codes 

5. At the end we create thematic maps with all necessary information in DIN A 4 format. 
Document delivery: Prepare a maximum of ten pages (text, diagrams, maps) on the thematic context (topic, UN 
goal, significance of the indicator, critical examination of the data situation, own calculation and interpretation of 
the results) in a document with common Office and GIS programs (Word, Excel, OpenOffice, LibreOffice, ArcGIS, 
QGIS etc.). Your elaboration should contain at least 1 diagram and at least 1 thematic map. Briefly introduce the 
chosen topic and interpret the result. Please indicate the sources used (including data sources) in a correct and 
comprehensible manner, as is customary for scientific research. 
Note: In this click-by-click instructions we present the processing of attribute data with Excel (commercial software, 
here Excel 2016) and LibreOfficeCalc (open software) in parallel and geo processing with ArcGIS Desktop (com-
mercial software, here ArcMap 10.5.1) and QGIS (open software). Thus the user has in any case the chance to 

                                                            

5 https://unstats.un.org/sdgs/indicators/database/ 

https://unstats.un.org/sdgs/indicators/database/
https://www.laenderdaten.info/laendercodes.php
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perform the processing with open software, or otherwise, depending on availability, to use common commercial 
software in his working environment. 
Problem statement 

 
Select a meaningful statistical data set on one of the SDG topics (e.g. poverty, hunger, .. peace, partnerships) 
with temporal statements (time series) related to the national aggregation level. This dataset should be com-
pletely downloadable (e.g. as ASCII, csv, xls) and can therefore be evaluated on the desktop with the standard 
tools known to you. Do not use a completely prepared indicator, but a raw data set. 

Topic here: Global trend in renewable energies 
For this example, the global trend in renewable energies will be examined. In other words, the exact extent to 
which the share of renewable energies in total energy consumption changed between 2000 and 2016. Indica-
tor 7.2.1 - Renewable energy share in the total final energy consumption (%)" (indicator EG_FEC_RNEW) is 
selected for this purpose. This is an estimated percentage, based on national data, of the share of final con-
sumption of energy derived from renewable resources in relation to total consumption.  
In addition to looking at the situation worldwide (spatially and temporally), we would like to make a comparison 
of countries. For this purpose, we look at one country on each continent, for which we choose the example: 
         Europe: Germany                         Australia: Australia             North America: Costa Rica  
        South America: Ecuador               Africa: Algeria                     Asia: Vietnam 

Data search

 
UN records 
The first step is to locate the relevant records; this can be done by navigating the UN website, or (often faster) by 
making a search using a search engine. Finally, the records can be found at: https://unstats.un.org/sdgs/indica-
tors/database/ 

 
Data search for SDG indicators 

At https://unstats.un.org/sdgs/indicators/database/, search for a data set on one of the 17 sustainability goals and 
consider what you want to (or can) present in the end, do not forget the time series reference. An overview of all 
UN indicators can be found in the document "Global indicator framework for the Sustainable Development Goals 
and targets of the 2030 Agenda for Sustainable Development". The metadata (i.e. what the indicator says, how it 
is collected, etc.) can be found in the Metadata repository. You should definitely take a look at this in order to 
adapt your evaluations accordingly and critically question them. 
 
 
 

https://unstats.un.org/sdgs/indicators/database/
https://unstats.un.org/sdgs/indicators/database/
https://unstats.un.org/sdgs/indicators/database/
https://unstats.un.org/sdgs/indicators/indicators-list/
https://unstats.un.org/sdgs/indicators/indicators-list/
https://unstats.un.org/sdgs/metadata/
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Topic here: Global trend in renewable energies 
Consumption of renewable energy includes consumption of energy from water, solid biofuels, wind, solar, liquid 
biofuels, biogas, geothermal energy, seawater and waste. Total final energy consumption is calculated from na-
tional reports and statistics as total final consumption minus non-energy consumption. This indicator is based on 
comprehensive, annually updated energy statistics on supply and demand for all energy sources - statistics that 
should be used to establish a national energy balance and thus have a fairly high reliability. Internationally agreed 
methods for energy statistics are described in the "International Recommendations on Energy Statistics" (IRES) 
adopted by the United Nations Statistical Commission and available at the following address: IRES6. The IRES 
time series dates back to 1990. 

 
SDG Goal 7 

Under Show table you can find a preview of the data and under Years you can select the period. At the beginning 
of August 2019, the data for the selected indicator cover a total of 4,624 observations for the period 2000 to 2016. 
It is important that these factual data can later be linked to the spatial data, i.e. the national borders (the relational 
operator JOIN), via a unique key. This is, as we will explain later, the column geoAreaCode, namely a numeric 
country code.  
In order to download the correct data set, it is necessary to click on the Years 2000 to 2016 tab. Then click on 
Show table to download the dataset as an Excel spreadsheet at the end of the page. If the data set meets your 
requirements, click on Download. 
We download the dataset in csv format, even if here some additional steps are necessary, because the data are 
different in this case (rows and columns transposed, so that a pivotation is necessary). Excel format would also 
be possible. In both cases, you have to check the cells for usable data types, which we describe for csv. 
 

                                                            

6 https://unstats.un.org/unsd/energy/ires/ 

https://unstats.un.org/unsd/energy/ires/
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SDG-Indikator 7.2.1 Renewable Energy share in the total finakl energy consumption 

Table structure 
The structure of the SDG tables is largely homogeneous. The only difference is the technical content of the indi-
cators. In the following the information important for your later elaboration is presented and explained: 
 Indicator 
 Series Description 
 GeoAreaCode 
 GeoAreaName 
 TimePeriod 
 Value 
 Units 
 Source 
Indicator: The SDG data are subject to a strict structure. It is divided into Goal, Target, Indicator, where Goal is 
the macro level, Target is the meso level and Indicator is the micro level. The indicator thus names the exact des-
ignation of the affiliation of the data to the UN targets. This information is very valuable because not all the data in 
the table comes from the indicator you have selected. It is advisable to process the metadata of each listed indi-
cator, as they have been selected to match your indicator. This may offer new interfaces. 
Series Description gives a short description or the name of the previously specified indicator. 
GeoAreaCode is a country ID selected by the UN. However, these do not correspond to the standardized country 
IDs. Nevertheless, this ID should be used for possible links later.  
GeoAreaName contains the country names. This column could also be used for the join of the table with the 
country shape file in GIS editing, but different spelling of the names is a hindrance here. 
TimePeriod indicates the year the data is viewed. In the metadata, the entire observation period can also be 
read. 
Value lists the values that you analyze and with which you will calculate. Pay particular attention to decimal num-
bers or possible 1000 digits for larger numbers. It should also be mentioned that the values are often subdivided 
again. This subdivision is indicated in one or more further columns. For example, the indicator 3.c.1 "Health 
worker density, by type of occupation" divides into the medical specialties in the column "Type of occupation".  
Units indicate the unit of the numerical values (value) and are therefore an important component of their later 
analysis. 
Source indicates the primary source of the indicators. You should pay special attention to these during your re-
search. Using this information, try to relate the results of your analysis to the political or economic situation in the 
areas you select. 
The metadata (what the indicator says, how it is collected, etc.) can be found in the Metadata repository7. You 
should definitely take a look at this in order to adapt your evaluations accordingly and to critically question them. 
                                                            

7 https://unstats.un.org/sdgs/metadata/ 

https://unstats.un.org/sdgs/metadata/
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The metadata provides information on how your data was structured and collected. Only with this information you 
will be able to interpret your data correctly. In addition, information on the period under review and the sources of 
the studies is also provided here. These will be particularly important in your later report. 
Each UN data set can have a slightly different structure, which is why the next step shows only one example of 
an indicator. Here it is important for you to get an overview of the data yourself and to define a question. Write it 
down in a structured way and search for statistical evaluation methods. Think about what you want (or are able) 
to display at the end, do not forget the time reference in addition to the spatial reference. 
Country borders 
Next, a data set with the country borders is required. On the Open Data Website Natural Earth8 you can find 
some matching vector data sets.  Natural Earth is a publicly accessible map dataset that is available at scales of 
1:10,000,000, 1:50,000,000, and 1:110,000,000 and does not require permission for use. However, you are wel-
come to quote the data source, e.g. in the form "Made with Natural Earth. Free vector and raster map data @ nat-
uralearthdata.com." 

 
Natural Earth Entry 

Under the Downloads tab, select vector data on the subject of cultural vectors on a scale of 1:50 000 000 and 
download the Shapefile Admin 0 - Countries. 
Data preparation  

 
Data organization 
In order to work efficiently on a project, it is very important to organize it properly. This starts with the folder struc-
ture on your computer. Create a folder (right click on the location => New => Folder). In this case it could be 
named "SDG". Make sure that you do not use any umlauts, special characters or spaces in the name. In some 
cases these can cause problems for the individual software types. Especially when processing with ArcGIS, error 
messages may occur. The length of the file path should also be kept as short as possible. Therefore in this exam-
ple "Sustainable Development Goals" was abbreviated as "SDG". 
In the next step some subfolders can be created. For this example you could create the following structure:  

                                                            

8 http://www.naturalearthdata.com/ 

http://www.naturalearthdata.com/
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 01_Basic data: In the folder "01_Basic data" only the basic data of the project are saved. These will not be 
changed later. 

 02_Analysis: The partial steps as well as the results of the analysis are stored in the corresponding folder 
"02_Analysis". When saving the substeps, make sure that they are properly named. Depending on the length 
of the project, you can select the current date as the name supplement here (for example 
SDG_10122018.xls). 

 03_Sources: The folder "03_Sources" contains, as the name already says, the sources of your project. Al-
ways save them directly in this folder, which can save you a lot of work when writing the document. 

 04_Dispense: You can save the final files in the folder "04_Dispense". This way you have an overview of all 
important documents for the later upload and do not forget to upload any. 

Excursus csv files: csv files are text files that can be read in software such as the Editor or Notepad++. In a ta-
ble-like structure, the columns are separated by a comma, space or semicolon. The format is supported by many 
software products and is therefore often used as an exchange format. You can learn more about this in the Data 
Formats tutorial9. 
UN data with Excel 2016 
This section uses the commercial program Excel 2016. If this program is not available to you, or you prefer to 
work with Free/Open Software for other reasons, you can switch to the section Data Preparation with LibreOffice 
Calc. 
Import data into Excel  
Before the UN dataset can be processed with a GIS, it must first be converted into an appropriate form. Open Ex-
cel and import the CSV file with the sustainability goals. Importing CSV files in Excel 2016 works as follows: 
Open Excel. Click Data => Retrieve External Data => From Text and select the CSV file containing the UN data. 

 
Input of CSV data 

Next, you need to specify the conditions under which the CSV file should be imported. At steps 1 and 2, select 
the settings as shown in the images. In step 3 you can change the data format of the columns and exclude indi-
vidual columns from the import. Both can be changed afterwards. The important thing with step 3 is that you im-
port the column with the numerical values first as text, since Excel has the habit of interpreting numbers with peri-
ods as decimal separators as dates. 
The indicator or goal designations can be imported as text, since they are not values with which to calculate. In 
case of a declaration as a number, Excel would also often output it as a date, so that the indicators would no 
longer be readable. 
 Goal (Text) 
 Target (Text) 
 Indicator (Text) 
 GeoAreaNames (Text) 
 geoAreaCode (Standard) 
 Value_xxxx (Standard) 

                                                            

9 https://learn.opengeoedu.de/tutorials#tutorial-datenformate 
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The value column(s), i.e. the column in which our energy values are located, must be declared as standard (i.e. 
as a number). However, since a decimal value is often present, a character must also be selected for this. This 
can be set under the button "More". For the settings a new window opens, where on the one hand the "1000 dig-
its" and on the other hand the decimal digits are listed. Since the SDG data are international, the decimal places 
are marked with a dot. The 1000 digits, on the other hand, are marked with a comma. You can now use these 
settings, if available, for the remaining value columns.  
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3 steps to convert csv to Excel 

After pressing the Finish button, the table will look something like this: 

Table view in Excel 

Tip: For further processing, it is advisable to create copies of the data for each important step, give them 
meaningful names and organize them sensibly on the computer.  

So at this point we create a copy of the previously created Excel dataset, once as csv- and once as xls-file, and 
name it UNSDG721Original.  
Data viewing and revision 
Now we look at the table in more detail and prepare it further. The columns have headings whose meaning and 
formatting are described in the metadata. A total of 249 lines are occupied (including one heading line). Many of 
the attributes (columns) listed in the table are not relevant for the actual calculation and can therefore be deleted.  
So we first reduce the table to the necessary columns (goal, target, indicator, geoArea-Code, geoAreaName, 
value_2000 .. value_2016) and have a much better overview. After deleting superfluous columns, the revised 
CSV file should now look like this: 

 
Desired appearance of the Excel table 

If the column values in your table are below each other (as it is shown here), it is now necessary to transpose the 
values per year so that one column is assigned to each value from 2000 - 2016. However, this is only necessary 
with the data as CSV, the Excel data are already correctly formatted. A pivot table is used for this purpose. Via 
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Insert (1.) => Pivot table (2) a new window opens in which the data area (all data cells) is selected (3). With the 
click on 4. a new table sheet with the pivot table is created. 

 
Insert the Pivot table 

To convert the individual years into columns for each country, it is necessary to select the GeoAreaName, Time-
Period and Value fields in the pivot table settings. These are then assigned to the column (TimePeriod), the rows 
(GeoAreaName) and the values. 

 
Formatting the Pivot table 

The table should now be displayed as shown here. 

 
Ready to use pivot table 

Now, each column of the pivot chart can be copied to a new worksheet. To make the country codes also availa-
ble, the pivot table has to be edited. Therefore, only the fields GeoAreaCode (as average value) and GeoAr-
eaName (as row) should be selected. 
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Adding the area codes 

The GeoAreaCode column can then also be copied to the new spreadsheet. Now only the columns Goal, Target, 
Indicator, SeriesCode and SeriesDescription have to be added. Since these are identical for each row, you can 
simply copy them for all rows and paste them into the new worksheet. The finished data table is shown below. 

 
Finished data table 

If your selected UN table makes it necessary, assign meaningful names for the headers (it is best not to use only 
numbers, otherwise ArcMap will not recognize them as headers). Finally, the data formats of the columns should 
be checked or set (select cells => right click => format cells; headers and text as text, numerical values as num-
ber). For several columns (e.g. all values from 2000 to 2016) hold down the Shift key when selecting headings. 

 
Formatting of all value columns as numbers 

 
Sort by size in ascending order 
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Formatted temporal table 

If you look at the data, you can see that some rows (Antarctica) has no values. For the visualization later on it is 
necessary to insert therefor no data value. In our case we insert -99. Therefore, the column Value_2000 should 
be sorted ascending and the empty fields should be filled with our no data value.  
Furthermore, there are some young countries like Montenegro or South Sudan, so there are no values before 
their founding year. In this case, we fill the empty fields with the value 0,0. The final table should look like this: 

  
Final data table 

The data preparation is now complete, save the table as CSV. 
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Store as csv 

UN Data with LibreOffice Calc 
In this section the data are prepared with LibreOffice Calc, this is intended as an alternative to the section Data 
preparation with Excel. Before the UN dataset can be evaluated with a GIS, it must be converted into a form that 
can be read and processed by a GIS. Open the CSV file of the UN dataset with LibreOffice Calc (Start LibreOffice 
=> Open button => Select file) and make the following settings for the import: 

 
Import in LibreCalc 
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After importing, all superfluous columns can be deleted. Every column except goal, target, indicator, geoArea-
Code, geoAreaName, TimePeriod, Value can be deleted. 

 
Desired appearance of the table 

In addition to the countries, the UN table also contains aggregated regions. Although these are not relevant for 
this evaluation, they do not interfere any further, since they disappear automatically during the later join. One 
problem, however, is that the values for the respective years are given in a single column and therefore the coun-
try names occur several times. For this reason, the year numbers (TimePeriod) and their values (Value) must be 
broken down into separate columns. This can be done with a pivot chart. Create a new pivot chart and set the 
time periods as columns, GeoAreaName and GeoAreaCode as row and values as the column value. 

 
Create a pivot chart 

The resulting pivot chart is shown below. 
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Final pivot chart 

Don't forget to delete unnecessary rows and columns. Assign meaningful names to the headers. Finally, the data 
formats of the columns should be checked or set (select cells => right click => format cells; headers and text as 
text, numerical values as number). 

 
Formattings 

Finally, missing values have to be filled. This is important for Montenegro and South Sudan. The empty fields are 
filled with 0,0.  
The data preparation is now complete, save the table as CSV. 

 
Store 

Country data with ArcMap 
General Settings 
We also take a look at the data of the country borders and prepare them for a later evaluation and visualization. 
To do this, open ArcMap and first set two general properties of the layer: map units in meters, display units in kilo-
meters. 
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General settings for layers 

Now add the shapefile with the country boundaries World_Countries_Generalized.shp via Add Data. 

 
Shape file of country borders 

A look into the table of country borders (right click on the layer in the layer window => open attribute table) shows 
that there are 239 entries. Some countries (TYPE) are also assigned to another country (Sovereign country or 
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Dependency), for example in the case of the British (e.g. the Cayman Islands namely United Kingdom) and 
French Overseas Territories (e.g. French Guiana). Since these territories are also listed separately in the SDG 
table, this is not an obstacle. 

Tip: Many columns can be hidden, because they are not needed for further processing, e.g. the names in dif-
ferent languages. You can do this by right-clicking on column header => Turn Field Off. Or - better for many 
changes - right-click on the layer => Properties => Fields. The following columns should be retained (FID, 
shape, featurecla, name, POP_EST ...) INCOME_GRP and ISO_N3.  

The clearly arranged table will look like this: 

 
Attribute data of the countries 

Save the status achieved with ArcMap as Map document with File => Save as with the name Country dataPre-
pared. 
Country data with QGIS 
General settings  
We also take a look at the data of the country borders and prepare them for a later evaluation and visualization. 
Open QGIS and adjust the projection of the map window first. Search for the EPSG code 4326, which allows a 
global representation.  
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Set projection in QGIS 

Then add the countries as a new vector layer to visualize them in QGIS. This can be done via Layer => Add Layer 
=> Add Vector Layer. 

 
Add a vector layer 

The result should look like the following figure: 
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Shape file with the boundaries 

A look into the table of country boundaries (right click on the layer in the layer window => open attribute table) 
shows that here some countries (ADMIN) are assigned to another country (SOVEREIGNT), for example in the 
case of the British (e.g. the Cayman Islands namely United Kingdom) and French overseas territories (e.g. 
French Guiana). Since these territories are also listed separately in the SDG table, this is not an obstacle. 

Tip: Columns can be hidden by right-clicking on Column header => Hide Column. Another way is to hide multi-
ple columns with a click on organize columns. The following columns should be still visible: featurecla, Name, 
POP_EST .. INCOME_GRP und ISO_N3. 

The table should look like the following: 

 
Attribute table of the countries 

Modeling 

 
In the next step, the data is modeled using a flowchart to indicate which data is linked and how. Detailed instruc-
tions can be found in the tutorial Modeling in UML and ER10 as well as in the tutorial UML Class and Activity Dia-
gram11. 

                                                            

10 https://learn.opengeoedu.de/tutorials/OGE-Tutorial_UML_Vorlesung-en.pdf 
11 https://learn.opengeoedu.de/tutorials/OGE-Tutorial_UML_uebung-en.pdf 

https://learn.opengeoedu.de/tutorials/OGE-Tutorial_UML_Vorlesung-en.pdf
https://learn.opengeoedu.de/tutorials/OGE-Tutorial_UML_uebung-en.pdf
https://learn.opengeoedu.de/tutorials/OGE-Tutorial_UML_uebung-en.pdf
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The activity diagram models the intended sequence, the class diagram models the data and its link. Open 
draw.io12, a program to produce various chart types, and use the blocks on the left side to draw a corresponding 
diagram. You can export the diagram as PNG under File => Export as. 

 
UML activity diagram 

 
UML class diagram 

Evaluation  

 
The evaluation can be done with the commercial desktop GIS ArcMap from ESRI, the open source desktop GIS 
QGIS or any other familiar GIS environment. Selected steps are shown here first in ArcGIS, then in QGIS. The 
                                                            

12 https://www.draw.io/ 

https://www.draw.io/
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temporal development is again considered from the point of view of the factual data, for which an evaluation using 
spreadsheet software, i.e. Excel or Libre Calc, is recommended. A spatial reference is established by comparing 
selected countries with the worldwide development. 
with ArcMap 
Import data 
Use Add Data to add the formatted UN data record to your open ArcMap. The table appears in the Table of Con-
tents of ArcMap. Right-click on the table and choose Open from the context menu. If the table has a similar shape 
to the one in the picture below, the previous work in Excel or LibreCalc was successful.  

 
UN-SDG-Tabelle 

If you have not already done so in the formatting step, now also open the attribute table for the country data  
World_Countries_Generalized.shp via Add Data. 



 

Professorship for Geodesy  
and Geoinformatics 

 

 
Agrar- und Umweltwissenschaftliche Fakultät ● Justus-von-Liebig-Weg 6 ● 18059 Rostock 

 
Shape files of country borders 

Data preparation 
The two opened tables can be arranged side by side: with Arrange Table e.g. vertically side by side. 

 
Arrange tables  
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Left: UN data, Right: Country borders 

In the next step, the join of the two tables is prepared. To do this, a column must be found that is identical in both 
tables for each country and uniquely assigns a value to each country. The country name is only suitable to a lim-
ited extent, since the spelling for the countries in the data records is not uniform. For example: Viet Nam and Vi-
etnam, Republic of Korea and South Korea etc. More suitable is the country code according to ISO 3166-1 given 
in both data sets. The matching column is called geoAreaCode in the UN data set and ISO_N3 in the data set of 
the country boundaries. 

 
Common key: right geoAreaCode, left ISO_N3 

But even here there are still small discrepancies, so the codes were entered in the UN data set without and at the 
country borders with leading zeros (4 vs. 004). At this point, the two tables still have to be harmonized. The fast-
est way to do this is probably to delete the leading zero of the data set of the country borders (ne_50m_ad-
min_0_countries) (to do this, open the table and click on the Edit Mode button). On this occasion you can also 
add the missing ISO codes for some countries (Norway: 578, Kosovo: 412). 
The next problem is that the country code column is created as a string for the country borders and as a long for 
the UN data, so the join does not yet work. To solve this problem, open the table of country borders and add a 
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column with data type Long. Right click on the new column => Field Calculator and enter "New field" = [ISO_N3]. 
The join can now be performed via this newly created field. 
Joining two tables 
The join is finally performed via Right click on Layer of country borders => Joins and Relates => Join with the fol-
lowing settings: 
1. Select column with the country name of the country boundary data set. 
2. Select the dataset which should be connected to the country boundary dataset. 
3. Select column with country name of the UN dataset. 
4. Keep all records to keep rows to which no values have been assigned. 

 
Join process 
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Join result 

The next step is to tackle the actual goal of presenting the trend in renewable energies from 2005 to 2015. To do 
this, you have to create a new field in the table in which the difference is to be stored. Open the table of the 
Shapefile Layer => Table Options => Add Field. Then choose a meaningful and short name for the difference 
(e.g. 2000_2016) and set the data type as Double, with precision 8 and scale 2. Right click on the new field => 
Field Calculator. In the Field Calculator, subtract the values for the year 2000 from the values for 2016. 
Before we go to the visualization, let's take a closer look at the data. You can see that some countries have a 
<NULL> value. In contrast to the number 0, this indicates that no values are available here (in contrast to Palau, 
for example, which had a 0% share of renewable energies in 2000 and 0% in 2016 and consequently also had 0 
percentage points growth). The <NULL> values were calculated in the Field Calculator as the number 0 and 
would therefore also be visualised and thus falsify the information content. Therefore you need to edit the table 
again (Editor => Start Editing). Arrange the data according to the 2000_2016 column (double-click on column 
header). Change the difference 2000_2016 of all zero-value lines by marking them with the CTRL key pressed 
and entering a unique value here via the calculator (Field Calculator), which otherwise does not appear in the 
data (e.g. -99). This value can then also be displayed separately in the visualization. 
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Replace NULL values with -99 

with QGIS 
Import data 
The next step is to add the UN dataset. You can do this via Layer => Add Layer => Add Delimited Text Layer. 
The new table is shown in the QGIS layer manager.  
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Add table in QGIS 

Click now with a right click at the table and select Open. The result should look like the following:  

 
UN-SDG table 

Data preparation 
To view the UN SDG table as well as the attribute table from the countries, you can move them next to each other 
with dock attribute table. 
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Docked attribute tables (left: country borders, right: UN data) 

The next step is to prepare the join of the two tables. Therefore, you have to find a column with identical values 
for each of the countries. The names are not so well suited in this case, because they are written in a different 
manner (Viet Nam and Vietnam). To avoid this, the column with the ISO 3166-1 values is ideal. The column is 
named geoAreaCode (UN dataset) and ISO_N3 (countries). 

 
Common key: right geoAreaCode, left ISO_N3_L 

Joining two tables 
It is important to know that the code is formatted in a different datatype (Long vs String). But in comparison to 
ArcGIS, this is no problem in QGIS. You are able to join datasets also with a different datatype. To do so, you 
have to click with the right mouse button on the countries layer and select Properties => Joins (1.) => +-Symbol 
(2.). Then select the SDG dataset (3.), the join column (GeoAreaCode; 4.) and the right column from the coun-
tries (ISO_N3; 5.). After this click OK (6.) and apply (7.) the join.  
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Join 

 
Make the join permanent 
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If you sort the resulting table the value_2000 field ascending, you can see that some fields are filled with <NULL>. 
These are the countries without any data.  
Now we are creating a copy of the countries dataset to make the join permanent. To do so, right click on the 
layer, Export => Save features as. The name of the dataset should be “nations”. After the export, our copied layer 
is also visible in the layer manager.  
Now we are able to calculate trends in the usage of renewable energy in the timeframe from 2000 to 2016. There-
fore, we have to add a new field where the difference is calculated. First open the attribute table of our new nations 
layer and click deselect all. Then open the field calculator, insert a short name for the new field (D00_16), set 
decimal number (real) as datatype with precision 8 and scale 2. Now you can substract the values of 2000 from the 
values of 2016. 

 
Calculate the difference 

If you sort the new column ascending, the differences in the development of renewable energy get visible. Equa-
torial Guinea has in 2016 37% less, Liechtenstein 63% more energy share from renewable ressources. Many 
countries don’t have any big differences. We make a short discussion of the data later on.  
Visualization  

 
To create an attractive printable map for your final report that follows the rules of cartography, it is advisable to 
consult the tutorial on cartography13 with common statements on maps. If you are not yet familiar with creating 
thematic maps, please read our tutorial on map design14. 
Again we will show you a solution with ArcGIS and one with QGIS. 
with ArcMap 
The layer can now be categorized and colored again in symbology according to a meaningful scheme. For this 
we select a quantitative highlighting under Properties (Symbology => Quantities => Graduated Colors), take e.g. 
6 classes (plus one class for the former <NULL>-values) and select a traffic light coloring for the representation. 
Red should represent a decrease, green an increase of renewable energies. 

                                                            

13 https://learn.opengeoedu.de/tutorials#tutorial-kartographie 
14 https://learn.opengeoedu.de/tutorials/OGE-Tutorial_Kartengestaltung-en.pdf 

https://learn.opengeoedu.de/tutorials#tutorial-kartographie
https://learn.opengeoedu.de/tutorials/OGE-Tutorial_Kartengestaltung-en.pdf
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Color coding 

 
Visualization by countries 
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Map layout 

To create a diagram for the development of renewable energies over time, select a country, copy the 
EG_FEC_RNEW value for the last 16 years and display it in a diagram (here with Excel) The result for Germany 
then looks something like this: A clear increase in renewable energies over the last 15 years. 

 
Time serie as chart 
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with QGIS 
The layer can now be categorized and colored using the style management (Layer Properties => Style) according 
to a meaningful scheme. For this we select a quantitative highlighting under Properties (Symbology => Quantities 
-= Graduated Colors), take e.g. 5 classes (plus one class for the NULL values) and select a traffic light coloring 
for the representation. Red should represent a decrease, green an increase of renewable energies. The class 
boundaries as well as the entries for the legend can be changed manually by double-clicking on the respective 
values. 
This will be demonstrated step by step using the year 2000. For the symbolisation, the column Value_2000 is 
selected using an expression (case when "721clean_6" IS NULL then -99 else "721clean_6" end) (1.). The expres-
sion sets all <NULL> values as -99 and thus recognizes them as data gaps.  
They are then classified as a green gradient (2.) in 6 classes (3.) (4.). The class limits are defined manually (5.) by 
entering values (6.) (7.). The labels are adjusted (8.) and finally the selected setting is executed (9). 

 
Color settings Value_2000 

The result is the following view for the year 2000, in which on the one hand the countries without data (in black, 
from Antarctica to Taiwan) are well recognizable. On the other hand, the proportion of renewable energy used in 
2000 can be differentiated to some extent on the basis of green tones. 
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View Value_2000 

We save the selected color scheme by right-clicking on Nations => Export => Save as QGIS Layer Style File in the 
editing folder. 

 
Save color settings 

We then proceed in the same way for the values of 2016. However, in QGIS it is not possible to load the represen-
tation directly in the concrete case, since the select statement must be adapted accordingly (case when 
"721clean22" IS NULL then -99 else "721clean22" end).  
In this case the classes are reset again. Consequently they have to be adjusted manually again. Nevertheless, 
styles can also be loaded and applied. 
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Apply color settings for other data set 

 
View Value_2016 

In the year 2016, the darker shades of green in Europe in particular will indicate the higher use of renewable 
energies. 
In order to emphasize this difference visually, we create a visualization in traffic light colors. Red should represent 
a decrease, green an increase of renewable energies. Since the difference between the countries without data 
would be 0 and therefore not distinguishable from countries with data that have not changed, we use a trick. We 
create a new copy of the shape file (see above) of the nation dataset, named NationBackground.shp. Now we color 
it so that all countries with -99 are colored black and all other countries are transparent. Now you can see the 
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Antarctica and other countries without data in black and unfilled countries like South Sudan or Oman, which have 
provided data only in the course of time. 

 
Background map 

Now we go analogous to the single years to the coloring of the difference data and evaluate the field D00_16. The 
sequence corresponds to the previous one, only a color gradation from red to green in 7 classes is selected, the 
limits are set manually [<-20, -10, -1, 1, 10, 20, > 20]. It is essential that the borders of the fields are narrower and 
grayed out. To do this, all classes are marked and the border line is edited using the button Symbol. In addition, a 
meaningful description of the classes is necessary. 
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Edit colors settings 

 
Difference 2016 to 2000 for all countries 

The last step is to create a thematic map with QGIS. For a better understanding, you can read the online tutorials 
about Cartography and Thematic Mapping.  
 

https://learn.opengeoedu.de/tutorials#tutorial-kartographie
https://learn.opengeoedu.de/tutorials/OGE-Tutorial_Kartengestaltung-en.pdf
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Thematic map production 
In order to create a sophisticated thematic map, a great deal of processing is usually required after the analysis in 
order to meet the demands of thematic cartography. We refer here again to the cartographic literature and our 
online tutorials on cartography and thematic cartography.  
In QGIS, thematic maps are created using the print layout. This can be found under => Project => New print lay-
out. We give the layout the name "SDG 2000 - 2016". Then the area for the map is drawn using the button Add 
new map to layout (1.). By clicking on Move content the map can now be moved to the desired position (2.). In 
the area Scale on the right side we enter 80.000.000, which corresponds to a scale of 1: 80.000.000, so that the 
map can be displayed full page (3.).  
A legend window is then added (4.). On the right an area with the legends appears. The heading "Legend" can be 
assigned to the legend here (5.). Here you can rename the individual fields accordingly (6.). It is important that 
Automatic update is deactivated (7.). Furthermore, unneeded elements, such as the original data table, can be 
deleted using the minus button (8.). To display the legend in two columns, we increase the number of columns in 
the "Columns" area (9.).  
Now we add the necessary map elements like title, scale bar (with kilometre indication), author, sources etc. via 
the Add element in the menu bar and get a quite acceptable map design (10.). A special feature is that the north 
arrow must be inserted as an image in QGIS. 
Note: A scale bar cannot be added in QGIS for world maps because of their projection properties. You are only 
able to add a scale bar for maps with an aquidistant projection. In this case, the values of the scale bar screwed 
up so we don’t draw it on the map. 

  
QGIS print layout 
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Final map 

Evaluation and visualization of time series 
with Excel or LibreCalc 
Now we return to the Excel or Libre Calc evaluation in order to analyse selected statistical measures as well as 
the temporal progressions. First we create a copy of the prepared data set, e.g. as a second table in the Excel 
file.  
Measurements 
First we eliminate all countries without data (-99) by sorting Value_2000 in ascending order and then manually 
deleting the rows with -99 completely (from the Aland Islands to Western Sahara). At the end of the table we add 
three new lines with the respective entries "Minimum worldwide", "Average worldwide" and "Maximum worldwide" 
to the place of the country names. We then calculate the values for Value_2000 at the respective position using 
the function "=Min(F2:F228)", "=MEDIUM VALUE(F2:F228)" and "=Max(F2:F228)". We then drag these functions 
in the row/column up to Value_2016. Then we format them as a number with 2 decimal places. 
The interpretation of the very different results for the individual countries is done later. 
Time diagrams 
To create a diagram for the development of renewable energy over time, we create another table, copy the head-
ings of the old table and the rows of the calculated values Minimum, Average and Maximum as numerical values 
into the table. Then we search for the desired 6 countries (Algeria, Australia, Costa Rica, Ecuador, Germany and 
Viet Nam) and copy their data into the new table. Delete the first 4 columns (from goal to geoArea code) to make 
diagram evaluations easier. The result looks like this.  

 
Country comparison 

Select two countries (select line while pressing the CTRL key), here Algeria and Germany and create a line dia-
gram. 

geoAreaName value_2000 value_2001 value_2002 value_2003 value_2004 value_2005 value_2006 value_2007 value_2008 value_2009 value_2010 value_2011 value_2012 value_2013 value_2014 value_2015 value_2016
Minimum worldwide 0,00 0,00 0,00 0,00 0,00 0,00 0,00 0,00 0,00 0,00 0,00 0,00 0,00 0,00 0,00 0,00 0,00
Average worldwide 15,17 14,73 14,82 15,21 15,60 14,95 15,50 15,72 15,50 16,71 16,91 16,86 17,00 17,53 17,24 17,16 17,21
Maximum worldwide 93,91 96,23 96,16 97,02 97,27 97,29 96,86 96,89 96,85 96,92 95,28 93,80 93,89 94,39 94,58 94,44 94,67
Algeria 0,43 0,43 0,51 0,47 0,44 0,58 0,41 0,41 0,3 0,31 0,26 0,18 0,18 0,13 0,07 0,06 0,08
Australia 8,42 8,37 8,74 7,15 6,68 6,71 6,85 6,95 6,79 7,11 8,13 8,31 8,29 9,09 9,22 9,16 9,32
Costa Rica 32,95 32,11 32,65 33,66 39,5 42,06 42,27 42,84 43,13 42,27 42,31 40,5 38,62 38,29 38,05 38,93 37,16
Ecuador 20,03 18,43 18,06 17,97 15,97 12,16 12,97 12,81 15,09 13,3 12,11 13,65 13,38 12,94 12,48 14,13 15,18
Germany 3,7 3,9 4,41 5,06 5,83 6,76 7,75 9,41 8,59 9,63 10,29 11,39 12,01 12,09 13,38 14,21 14,17
Viet Nam 57,97 56,36 52,42 51,03 45,99 44,36 44,47 42,11 39,46 37,17 34,8 36,53 38,12 37,71 36,98 34,73 32,71
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Comparing Algeria and Germany 

Similarly, we create a time diagram for all 6 countries considered in a worldwide comparison. 

 
Six countries in comparison to the worldwide situation 
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Interpretation 

 
To interpret your results, go back to the pages of the United Nations and read about the significance of the indica-
tor you have chosen. 
Interpretation of the example: 
In the 7th objective for sustainable development, the UN calls (among other things) for a substantial increase in 
the share of renewable energies. According to the UN, the generation of energy from fossil fuels, which is still 
dominant today, accounts for 60% of all greenhouse gas emissions and is thus one of the main driving forces be-
hind anthropogenic climate change. The fulfilment of this objective is therefore closely linked to objective 13 - cli-
mate change. On the other hand, renewable energies represent a great opportunity, especially for developing 
countries, to become independent of the import of energy (carriers) from abroad or to electrify remote areas in the 
first place. Against this background, this paper describes the extent to which the share of renewable energies in 
total energy consumption changed per country between 2000 and 2016. The indicator 7.2.1 - Renewable energy 
share in the total final energy consumption (%) (indicator EG_FEC_RNEW) of the UN sustainable development 
goals was selected for this purpose. This is an estimated value based on national estimates. 
European countries have developed almost exclusively positively (cf. the visualizations 2000 to 2016), as have 
most developed countries. In the period 2000 to 2016, Germany recorded an almost linear increase in the share 
of renewable energies (from 3.7% to 14.2%, see diagram), whereas Algeria recorded a regression.  
The general trend in the developing and emerging countries in South America, Africa and Asia is a decline in the 
share of renewable energies. However, the development of absolute energy consumption remains unnoticed in 
this presentation. In China, for example, primary energy consumption almost doubled between 2005 and 2015 
(from 1793 to 3010 million tonnes oil equivalent, i.e. enormous new capacities of renewable energies were built 
up during this period to "only" drop 6 percentage points). 
Sources 
Indicator 7.2.1.: https://unstats.un.org/sdgs/metadata/?Text=&Goal=7&Target=7.2=&Goal=7&Target=7.2 
Statistical data: https://de.statista.com/statistik/daten/studie/42182/umfrage/primaerenergieverbrauch-von-china-
in-oelaequivalent/ 
Country data: https://www.naturalearthdata.com/downloads/50m-cultural-vectors/ 
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